XTL2500 MPL Not transmitting...

Moderator: Queue Moderator

Post Reply
Posts: 346
Joined: Sun May 24, 2009 12:23 am
What radios do you own?: Desktrac, XTL/XTS's & XPR's

XTL2500 MPL Not transmitting...

Post by fchrist16 »

Strange issue here. I am setting up MPL like I have with every other XTL2500 I've had but for some reason, my UHF XTL2500 DOES NOT want to let me pick the MPL out of the MPL list. The softkey is there, I can scroll through the PL's I have set and HIT SEL (Select) but it will not TX the PL. Checked and verified several different ways.

Does anyone have an idea? I'm sure it's a simple *DOH* that I'm skipping over somehow...


-Frank C.
Posts: 3607
Joined: Sun Sep 09, 2001 4:00 pm

Re: XTL2500 MPL Not transmitting...

Post by Jim202 »

I could be wrong with my age and memory getting bad, but some years back, Motorola made a change to the programming software that effected the MPL use on the XTL. I used the feature in my radios as I traveled frequently and ran into new repeaters that I couldn't key up. So I had set up the multi PL feature and it worked great. But after a new programming version was installed, it no longer worked.

Several of us complained to Motorola about this change, but it was never fixed as far as I know. So this might be what your experiencing.

Post Reply

Return to “ASTRO25 Series (XTS/XTL 1500/2500/5000) Subscribers”